After upgrade, recurring tasks stop running past midnight
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After upgrade, recurring tasks stop running past midnight

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Article ID: 211647

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Seen in 12.3.3 and 12.3.5, C_PERIOD or PERIOD tasks with a start time before midnight and end time well after midnight do not run past midnight sometimes.  So far the scenarios are:

FIRST SCENARIO

1) Create a Timezone, it should be UTC-7:00 and no Defined daylight saving time
2) Create a script that does anything
3) Execute recurring on the script with:
    Time Zone set to the timezone created in #1 above
 in intervals of every 1 hour 0 minute
 Allow one overlap checked
 Between 13:00 and 12:59
 The rest default
4) Let script run past midnight

Expected behavior
Script runs every hour on the hour 24 hours a day

Actual behavior
Script runs every hour from 1300 to 2300 and then does not run again until 1300
after 0000, eh_nextcheck shows 1300 on C_PERIOD

This only affects objects that were in the activities window pre-upgrade OR that were in the activities window when a timezone was not defined in the working client.

 

SECOND EXAMPLE:

1) Create a timezone with the following attributes:
Time Zone is UTC
Define Daylight Saving time, advance normal time by 60 minutes
Change to DST on:
March
2nd Sunday
8:00 AM
Revert to Normal Time on:
November
1st Sunday
8:00 AM
2) Create a simple script object
3) Create a PERIOD object for every 15 minutes with a start time of 20:00 and an end time of 02:00
4) Execute recurring on the script.  Add the timezone from step 1, add the period object from step 3 above
5) Wait for one full execution of period

Expected result:
script object should run at:
20:00, 20:15, 20:30, 20:45
21:00, 21:15, 21:30, 21:45
22:00, 22:15, 22:30, 22:45
23:00, 23:15, 23:30, 23:45
00:00, 00:15, 00:30, 00:45
01:00, 01:15, 01:30, 01:45
02:00

Actual result:
script object only runs to 23:45 and then does not run again until 20:00 next day:
20:00, 20:15, 20:30, 20:45
21:00, 21:15, 21:30, 21:45
22:00, 22:15, 22:30, 22:45
23:00, 23:15, 23:30, 23:45

This only affects objects that were in the activities window pre-upgrade OR that were in the activities window when a timezone was not defined in the working client.

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Cause

This looks to be caused by a defect where the working client where a recurring tasks is running does not have a timezone defined

Resolution

This issue has been fixed with 12.3.7 and requires an update to the components: Automation Engine, AWI, Initialdata and Utilities

Workarounds:
Be sure there is a timezone defined on the working client (client where tasks are running)
Once a timezone is defined, stop and start all affected recurring tasks

If the issue still occurs:

Open a case with Support and provide the following:
1) Go to Process Monitoring, right-click period object, choose Modify -> Modify Execution; gather the details there
2) If a timezone is defined in item 1 above, send an .xml export of the timezone
3) Also provide an .xml export of the timezone defined on the client where the task runs.