Upgrading to DLP 15.8 with Oracle 12.2.0.1

book

Article ID: 211573

calendar_today

Updated On:

Products

Data Loss Prevention

Issue/Introduction

Is it possible to upgrade to Data Loss Prevention (DLP) 15.8 from Oracle 12.2.0.1, or does Oracle need to be upgraded to 19c first?

Cause

As per the DLP System Requirements and 15.7 MP1 Release Notes, Oracle 12.2.0.1 is not supported in DLP 15.8.

Environment

  • Release : 15.8
  • Component : DLP Enforce, Oracle 

Resolution

Starting with DLP 15.8, Oracle 12c (version 12.2.0.1) is not supported.

DLP 15.8 requires Oracle 12.1 or Oracle 19c (Standard or Enterprise edition).

Although the System Requirements documentation states "The Symantec Data Loss Prevention database schema is supported on all editions of Oracle." - schema support only extends to supported versions of Oracle, such as 12c (12.1.0.2) and 19c. Supported editions do not include deprecated versions (such as 11g, 10g, or 12.2.0.1).

Further clarification of our support policies, specifically in relation to the Database version for DLP, can be found in the following KB article:

What would occur in current releases if the backend Oracle DB is not certified or unsupported ? (broadcom.com)

Additional Information

If you are currently running Oracle 12.2.x, you can perform a dbupgrade or dbexport / import to Oracle 19c.