Error "AHD58009:Could not create Incident. Reason: INVALID - AHD03055:Data partition Create restriction on Request" When trying to create ticket through maileater in SDM

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Article ID: 211532

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When trying to create a ticket through maileater, the ticket is not created and the following error appears in stdlog:

Error:

spelsrvr            10676 TRACE        i18nMsg.c              588 Arg[0] = Incident
spelsrvr            10676 TRACE        i18nMsg.c              588 Arg[1] = INVALID - AHD03055:Data partition Create restriction on Request
spelsrvr            10676 ERROR        cr_chg_text_api.spl   1420 AHD58009:Could not create Incident. Reason: INVALID - AHD03055:Data partition Create restriction on Request

Cause

This is a restriction set at the code level for Access types not consuming licenses. This issue is not caused by a Data partition constraint set to the role or contact. 

Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Resolution

This issue has 2 possible solutions:

1. Enable license flag for the access type being used.

2. Avoid setting the affected end-user (customer) in the maileater rule. The affected end-user must be the same user who sends the email to maileater mailbox. This is a restriction for end-users not consuming a license.

Additional Information

I cannot update an Incident using Maileater if I am not the affected end user