Nodejs agents not showing frontend/backend metrics

book

Article ID: 211511

calendar_today

Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

 

Nodejs agent is not reporting frontend/backend metrics.

Only seeing the Agent Stats and Node.js Runtime metrics.

Nothing has been changed in the nodejs agent or nodejs collectors.

Using Node Version 10.16.3 and Probe Version 1.11.1.

Sometimes after restarting the Infrastructure Agent, there might be some frontend/backend metrics in the Investigator of the workstation or the Metric View in DX APM but then it stops reporting values in few minutes.

Here is a screenshot of one agent where the stats and runtime metrics are showing but no frontend/backend metrics.

Cause

 
 

The reporting queue limit was reached, the Infrastructure agent will report this sort of message to indicate dropping of messages

[INFO] [IntroscopeAgent.ReportingQueue] ReportingQueue drop total:  13659

Environment

Release : SAAS

Component : APM TEAM CENTER/ACC

Resolution

 

On Infrastructure Agent:

Increase the queue size to 300.

Add the following property in IntroscopeAgent.profile

introscope.agent.reportingqueue.size=300

Restart the Infrastructure Agent

Additional Information

 

Note that the reportingqueue.size property relates to the amount of connections from probes into the Infrastructure Agent, not the actual number of messages queued/dropped.

Attachments