The Spectrum SpectroSERVER process is starting and stopping automatically
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The Spectrum SpectroSERVER process is starting and stopping automatically

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Article ID: 21149

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The SpectroSERVER starts and stops automatically and the SCP shows the following message: 

Environment

Release:
Component:

Cause

This situation could happen if the SpectroSERVER had crashed and it was configured to AUTORESTART in the $SPECROOT/lib/SDPM/partslist/SS.idb file;

The .VNMDB.LOCK file will exist under $SPECROOT/SS directory and the Spectrum Process Daemon will try to start the SpectroSERVER every time.

Based on this behavior when the SpectroSERVER attempts to start it sees there is a .VNMDB.LOCK file and therefore cannot start the SpectroSERVER.

Looking into the VNM.OUT file you can see the following messages as an example:

Database already locked by: spectrum,
...
...
Could not open the database. VNM exiting.
Landscape not initialized. VNM exiting.

 

Resolution

In this case the solution is:



  • Close SCP
  • Stop the "SPECTRUM Process Daemon" service
  • Set AUTORESTART;n; in the SS.idb file
  • Delete the $SPECROOT/SS/.VNMDB.LOCK file
  • Restore a previously saved SpectroSERVER database from prior to the crash.
  • Start the "SPECTRUM Process Daemon" service


NOTE: It is not recommended to configure the SpectroSERVER to AUTORESTART in the SS.idb file because if the SpectroSERVER is not brought down gracefully, there is a risk of database corruption that should be addressed before restarting the SpectroSERVER process.

Additional Information

Please reference the "Install Ticket Files" section of the documentation for more information.

Attachments

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