Windows installation fails with 'AppWorx_Debug.log (Access is denied)' error
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Windows installation fails with 'AppWorx_Debug.log (Access is denied)' error

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Article ID: 211413

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

When installing Applications Manager in Windows OS and from command line, the following error can be seen:

C:\Applications.Manager_AM.Image_SOLARIS.AIX.LINUX.WINDOWS_9_3_2+build.1\SOLARIS.AIX.LINUX.WINDOWS>cdinstall.bat
Leave Window up until Installation is complete

C:\Applications.Manager_AM.Image_SOLARIS.AIX.LINUX.WINDOWS_9_3_2+build.1\SOLARIS.AIX.LINUX.WINDOWS>internal_adoptopenjdk_8\bin\java.exe -cp v9\* -DLIB_HOME=v9 -DDEBUG=true -Dlog=C:\AppWorx_Debug.log com.appworx.install.Install
Debug enabled at 3/25/21 11:35 AM
main: .Install: Install started...
java.io.FileNotFoundException: C:\AppWorx_Debug.log (Access is denied)
C:\AppWorx_Debug.log
java.io.FileNotFoundException: C:\AppWorx_Debug.log (Access is denied)
        at java.io.FileOutputStream.open0(Native Method)
        at java.io.FileOutputStream.open(FileOutputStream.java:270)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:213)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:162)
        at com.appworx.install.Install.main(Install.java:159)

 

Environment

Release : 9.3+

Component : APPLICATIONS MANAGER

Cause

CMD or command line does not have admin rights

Resolution

Open up CMD with "Run as Administrator" option and rerun the installation.