create_package is no longer supported - error when running command on Mac OS 11

book

Article ID: 211401

calendar_today

Updated On:

Products

Data Loss Prevention Endpoint Prevent

Issue/Introduction

  • You have Mac OS 11 (Big Sur) and want to prepare the DLP Endpoint Agent package for mass deployment.
  • You run the sudo sh ./create_package command but receive the message that,  "create_package is no longer supported. For installation instructions refer to the Install_ReadMe.rtf file"
  • That file only contains instructions for manual deployment and references to the Installation Guide for further information, which then describes the create_package instructions once again

 

Environment

Release : 15.7 MP2, 15.8.x, Mac O11 (Big Sur)

Component : DLP Endpoint agent

Resolution

  • On Mac OS 11 (Big Sur) with 15.7 MP2 endpoint agent or later, there is no requirement to package the agent using the create_package command.
  • The agent can be deployed both manually and via third party Software Management tools using the sudo sh install_agent.sh command executed from within the unzipped agent package created on the console.