search cancel

OWB: why do we not get a version checking error when trying to use OWB 1.2.2 connected to Clarity 13.1?

book

Article ID: 21136

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Description:

Historically, when opening a project schedule in a version of Open Workbench (OWB) that doesn't match the Clarity version, a version mismatch error is thrown:

     Build Version mismatch between client and server (%s). Contact your administrator for further details.

We found that users with OWB 1.2.2 (from Clarity 12.1.x) can connect to Clarity 13.1 without getting an error.

 

Environment

Release: ESPCLA99000-13.2-Clarity-Extended Support Plus
Component:

Resolution

Solution:

CA only implements version checking on the client software when a major code change has happened between Clarity and OWB.

Since our customers may not be able to upgrade all their client machines at once we do not prevent them from using earlier versions so they have time to get all machines upgraded.

We do not test and therefore do not support earlier versions of OWB with current releases of Clarity.

We recommended using the version shipped with Clarity.

If your users encounter an issue while using an earlier version we will request them to recreate it on the current release before looking at it further.