CAUAJM_E_18402 ORA-03113: end-of-file on communication channel

book

Article ID: 211346

calendar_today

Updated On:

Products

CA Workload Automation AE

Issue/Introduction

Not able to onhold off hold Autosys Jobs (Autosys is down) Primary and secondary

chk_auto_up when executed on the primary server shows shadow scheduler is not running

 

Cause

[03/23/2021 14:27:11]      CAUAJM_E_18416 Event Server: <xxxxxxx>  Failed Query: <BEGIN :RetVal := ujo_batch_pkg.ujo_batch_get_event (:I_time, :I_time_prev, :RefCursor); END; <<1616489831,0>>>
[03/23/2021 14:27:11]      CAUAJM_E_18402 ORA-03113: end-of-file on communication channel

[03/23/2021 14:27:11]      CAUAJM_E_18416 Event Server: <xxxxxxx>  Failed Query: <update ujo_alamode set int_val = (select int_val from ujo_alamode where type='DB') where type = 'DB'>
[03/23/2021 14:27:11]      CAUAJM_E_18402 ORA-03113: end-of-file on communication channel

There was a timeout setting in the firewall between the primary and shadow schedulers which was closing the connection after the timeout was reached

After increasing the timeout for firewall to 8 hours, We were getting error after 8 Hrs.

Environment

Release : 3.3

Component : WORKLOAD CONTROL CENTER

Resolution

Autosys maintains a constant pool of database connections. We do not close any connection unless it becomes invalid.

We suggest configuring the firewall without any timeout set for the database connections.