Upgrade Error with Policy Server

book

Article ID: 211330

calendar_today

Updated On:

Products

CA Single Sign On Agents (SiteMinder)

Issue/Introduction

Getting following message while trying to upgrade the existing policy server R12.8SP1 to R12.8SP4.

 

 Default Install Folder: /opt/CA/siteminder

ENTER AN ABSOLUTE PATH, OR PRESS <ENTER> TO ACCEPT THE DEFAULT
      :

 

===============================================================================
Cannot upgrade from SiteMinder Policy Server  SP 0
--------------------------------------------------

SiteMinder Policy Server  SP 0 is installed.  Upgrades are supported from 4.51
SP05, 4.61 SP05, 5.0 SP01, 5.5 SP02, 6.0 and 12.0 .  Select 'OK' to exit
installation.

Cause

SiteMinder uses InstallAnywhere and relies on .com.zerog.registry.xml file to keep record of what product components are installead.

Only 1 and matching product component .com.zerog.registry.xml file need to be found by the installer or it may get into confused state.

 

This file usually is found under the user home folder, in the /var folder or in the product installation folder.

 

Environment

Release : 12.8

Component : SITEMINDER POLICY SERVER

Resolution

Issue was resolved by keeping one zerog file under the smuser home.