We are getting multiple wrong alerts from the ASM monitoring jobs (asm.saas.broadcom.com)
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We are getting multiple wrong alerts from the ASM monitoring jobs (asm.saas.broadcom.com)

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Article ID: 211112

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Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction

We are getting multiple wrong alerts for the ASM monitoring jobs.

 

Why are the monitoring station are giving an issue?

Seeing frequent errors: (5290) Script failed at step 7: no such element: Unable to locate element: {"method":"id","selector":"_Peoplefinder_INSTANCE_6BdyZPcq8bQC_searchString"}

 

 

 

 

 

Environment

Release : 10.0

Component : APP SYNTHETIC MONITOR ENVIRONMENTAL

Cause

This is a case of monitor failing with a false positive because the customer did not create a Webdriver script correctly. 

Resolution

Engineering believes that the monitor is failing with a false positive error because the Webdriver script needs modifications to eliminate this .

Please try:

-Use clickAndWait instead of Click in all your scripts. This ensures  the element with the given selector is present before being clicked. Also use typeAndWait instead of type

- The alert is not incorrect, Previous steps are executed too fast . So the Login form was not correctly submitted

The check failed since it expects the page to be logged in


For the education, we have a guide on how to create scripts here: https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/app-synthetic-monitor/SaaS/getting-started/track-website-performance-with-monitors/Build-WebDriver-Scripts.html