dSeries: Email notification failed to send email
search cancel

dSeries: Email notification failed to send email

book

Article ID: 211091

calendar_today

Updated On:

Products

CA Workload Automation DE CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE - Scheduler (dSeries) CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

User has defined multiple email address or lists in mail notification for job failures (or other states).  The mails are not being sent out by dSeries server.

Environment

Release : 12.x

Component : CA WORKLOAD dSeries

Cause

The tracelog shows the following errors:

00XXXXXX 00:00:12.345 [essential] [ERROR] EmailNotification: [2021-03-01_06:30:06.624] Exception: No recipient addresses
javax.mail.SendFailedException: No recipient addresses
at javax.mail.Transport.send0(Transport.java:210)
at javax.mail.Transport.send(Transport.java:124)
The application or job using variable for email addresses may have been incorrectly setup. E.g
 
APPL.SpecialMailVar="[email protected],[email protected]";

 

 

Resolution

If using mail variables to populate the email field, then the following example will not work
 
APPL.SpecialMailVar="[email protected],[email protected]";

 

The above example will not work as Javascript will take the whole string as one email address.  You can only have one mail or use a list.  Define one email list which has multiple users in it.

APPL.SpecialMailVar="[email protected]";

Additionally, define each email address separately in the email field.