After changing user groups, Primary OneClick server runs out of memory and crashes with hprof file

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Article ID: 211040

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Updated On:

Products

CA Spectrum

Issue/Introduction

Very soon after we made some changes to our OneClick Users structure, the OneClick server crashed, out of memory with a hprof file.

Why did this happen and what can we do to prevent this from happening again in the future?

 

 

Cause

Too many users were connected into OneClick when the changes were made, causing OneClick to use up additional memory which was required to update all active users.

Environment

Release : 10.4.x

Component : Spectrum OneClick

Resolution

Problem was caused by making a change to User Groups while many users were connected which caused OneClick Server to send an update to all OneClick clients.

Engineering suggests that any changes done to the users should be done after hours or when less users are connected to prevent this from happening again.