"sdk_postinterview.sh" failed with exit code 21

book

Article ID: 210951

calendar_today

Updated On:

Products

CA Workload Automation AE

Issue/Introduction

When trying to upgrade to WCC 11.4.7, receiving the below error message when trying to update the sdk:

[CAPKI] Failed to move /opt/CA/SharedComponents/CAPKI/CAPKI5/Linux/x86/32/lib/qHcC5P  to /opt/CA/SharedComponents/CAPKI/CAPKI5/Linux/x86/32/lib/libcapki.so [3]                           │
│ [CAPKI] Failed to install files                                                                                                                                                           │
│ [CAPKI] Install unsuccessful, return value is 3                                                                                                                                           │
│ [CAPKI] Parameters: mode=install, caller=WAAE1136, instdir=, env=all, verbose=true                                                                                                        │
│ [CAPKI] This installer contains CAPKI Version 5.2.5                                                                                                                                       │
│ [CAPKI] Using install directory as specified by CASHCOMP                                                                                                                                  │
│ [CAPKI] Installation directory: /opt/CA/SharedComponents/CAPKI                                                                                                                            │
│ [CAPKI] Checking for Permissions                                                                                                                                                          │
│ [CAPKI] Proper permissions are set for installation directory                                                                                                                             │
│ [CAPKI] Disk space is available                                                                                                                                                           │
│ [CAPKI] Existing Version RV=1                                                                                                                                                             │
│ The CAPKI install failed and returned with a code = 3                                                                                                                                     │
│ 01:09:18 !!  Script executed with error: 21  

Cause

McAfee was running on the Linux machine preventing the CAPKI to be upgraded.

Environment

Release : 11.4.7

Component : WORKLOAD CONTROL CENTER

Resolution

Disabled McAfee to do the upgrade and then re-enabled it after the upgrade.