PM - Cannot upgrade from JasperReport 7.1.1 to 7.1.1 (SP1)

book

Article ID: 210936

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

Getting below error in the CABI install log when trying to upgrade from CABI JasperReports 7.1.1 to 7.1.1.1 (7.1.1 SP1):

[[email protected] tmp]# tail CABusinessIntelligence_install_2021_xx_xx.log
DEBUG Upgrade.fileValidate():201 - Versoin.txt file path in cainstall : /tmp/ca_install/version.txt
INFO  Upgrade.readVersionFile():324 - path of the version file :/opt/application/CA/CA Business Intelligence/apache-tomcat/webapps/jasperserver-pro/version.txt
INFO  Upgrade.readVersionFile():348 - Version of the of file :/opt/application/CA/CA Business Intelligence/apache-tomcat/webapps/jasperserver-pro/version.txt is 0
DEBUG Upgrade.fileValidate():211 - Installed webapp version  : 7.1.1
INFO  Upgrade.readVersionFile():324 - path of the version file :/tmp/ca_install/version.txt
INFO  Upgrade.readVersionFile():348 - Version of the of file :/tmp/ca_install/version.txt is 0
DEBUG Upgrade.fileValidate():216 - Installer version  : 7.1.1
ERROR Upgrade.fileValidate():220 - Latest version of CA Business Intelligence already installed
ERROR ValidateAppServerForSilentInstallation.install():79 - AppServerMain returned with one or more error codes as printed below
ERROR CABIUtil.printCABIException():109 - ErrorCode : 16230   ErrorMessage : The latest CA Business Intelligence version is already installed

Cause

The CABI 7.1.1 SP1 is just for fixes and is not intended as a new version

Environment

CABI 7.1.1 SP1

Resolution

As a workaround follow below steps:

- Install CABI 7.1.1 SP1 on a new server
- Migrate (export/import) the reports from the old CABI 7.1.1 server