UIM - Primary hub down / Restart Looping / Unable to connect to IM

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Article ID: 210926

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Updated On:

Products

DX Infrastructure Management

Issue/Introduction

This technical document covers a scenario where the primary hub robot is not functioning as expected. 

The symptoms experienced are as follows:

- Unable to connect to the Primary hub via IM. 
- Primary hub nimsoft robot watcher service appears to be lopping. 
- Primary hub logs and robot controller logs display connection or communication errors. 

Cause

On further inspection of the Primary hub robot.cfg file, the file appears to be corrupt and / or has missing sections required for the hub to start, and run as expected. 

Example - One or all of the follow sections might be missing or contains incorrect information:

   robotname = 
   robotip = 

   hub = 
   hubrobotname = 
   hubip = 
   hubport = 

In this situation, the "robotname" and "robotip" values were missing. 

 

Environment

Release : 20.3

Component : UIM - HUB

Resolution

1. Deactivated the Primary hub nimsoft robot watcher service. 

2. Created a backup copy of the current robot.cfg file. 
- Located here on the Primary hub system: \Nimsoft\robot

3. Manually entered the correct information for the below sections: 

   robotname = <entered robotname here>
   robotip = <entered robotip here>

4. Saved the file and then reopened to confirm the changes were saved. 

5. Activated the Primary hub nimsoft robot watcher service. 


Additional Information

If the above steps do not resolve the issues faced or clarification is required before making changes to the production system, please contact Broadcom Technical Support.