Admin UI External Authentication - Cannot Import CA Certificates

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Article ID: 210912

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Updated On:

Products

SITEMINDER

Issue/Introduction

Customer is trying to configure external administrator authentication for the AdminUI over a secure connection and getting an error while attempting to import the CA certificates. The same cert has been successfully imported to AdminUI instances on other hosts without problems..  This is the error:

"An error occurred while updating the list of trusted CA certificates. Please ensure the trusted certificate you are using is valid.  If the problem persists, check the error logs for additional details."

Cause

We were not able to determine the root cause of this error.

Environment

Release : 12.8.03

Component : SITEMINDER WAM UI

Resolution

We worked around the problem by using the keytool command to import the certs into the JBoss trust store.  Here is the syntax:

keytool -import -trustcacerts -alias root -file Thawte.crt -keystore truststore.jks