SpectroServer Down on Weekend post upgrade to 20.2.7

book

Article ID: 210823

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

We have recently upgrade Spectrum to 20.2.7. Twice since we observed SS down for both Primary and Secondary.  The timings of both crashes coincide with our Qualys security scan.

The below message was observed in VNM.OUT

Mar 06 23:46:38 ERROR at CsCifFrn.cc(1225): Connection Interface Versions Incompatible
Version for this applications is: 2  Foreign application does not have a version number.
Mar 06 23:46:44 ERROR at CsCifFrn.cc(1225): Connection Interface Versions Incompatible
Version for this applications is: 2  Foreign application does not have a version number.

Environment

Release : 20.2

Component : Spectrum Core / SpectroSERVER

Resolution

10.04.03.D131 was built for this crash.  Please contact support to request a copy.

REQUIREMENTS

SPECTRUM 10.04.03 is the prerequisites for installation of this patch.

This patch needs to be installed on SpectroSERVER.

OVERVIEW 

This is a Debug patch for the following issue:

DE496191 Details:
SpectroServer Down on Weekend post upgrade to 20.2.7  
Symptom : Crash observed in Qualys security scan in OpenSSL zlib_stateful_init API.
Resolution: zlib_stateful_init method is part of OpenSSL in the case of OpenSSL build with zlib.Re-built OpenSSL without zlib.
(DE496191, 32588563)

 

BILL OF MATERIALS

ReleaseNote.D131.txt 
runme (Linux)
uninstall_D131.pl (Linux)
libGlobl.so.1 (Linux)


runme.exe (Windows)
uninstall_D131.exe (Windows)
libGlobl.dll (Windows)