Sqlserver probe - not connecting - testing fail
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Sqlserver probe - not connecting - testing fail

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Article ID: 210778

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We are facing an issue with the SQL Server probe profile connection testing. After reviewing the SQL Server log, we have identified the following error messages:

Mar 12 18:43:52:058 [13756] sqlserver: Profile: test connection profile, data engine connecting to database DB, using connection test connection, user: NimsMonitor, winauth: 0, encr: 0, tls_enable: 0 

Mar 12 18:43:52:058 [13756] sqlserver: (CreateConnString) Starting for profile - test connection profile 
Mar 12 18:43:52:058 [13756] sqlserver: ptConn->ntauth=0, [0][][DB][(null)] 
Mar 12 18:43:52:058 [13756] sqlserver: (CreateConnString) Provider=MSDASQL;Driver={SQL Server};Server=DB;Database=master;UID=DB;PWD=*****;Encrypt=no;MultipleActiveResultSets=yes; 
Mar 12 18:43:52:058 [13756] sqlserver: Profile: test connection profile/test connection checkpoint/Connect - DB Provider: Code=0x80004005 Source=Microsoft OLE DB Provider for ODBC Drivers Description=[Microsoft][ODBC SQL Server Driver][Shared Memory]SSL Security error  
Mar 12 18:44:48:998 [13384] sqlserver: Profile: DB, connect retry 2

Environment

Release: DX UIM 23.4 CUX

Probe: SQLSERVER any version

Cause

The TLS 1.2 was disabled.

Resolution

Enabling TLS 1.2 on the SQL Server will resolve this issue.

In certain environments, it may also be necessary to disable SSL 2.0, SSL 3.0, PCT 1.0, TLS 1.0, TLS 1.1, as well as RC4 and DES.

Additional Information

Also ensure that you are using the correct User ID and Server name (refer to SQLServer IM Configuration