Not able to deploy WASP probe - getting wasp error - The system cannot find the file specified

book

Article ID: 210756

calendar_today

Updated On:

Products

DX Infrastructure Management CA Unified Infrastructure Management for z Systems CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) NIMSOFT PROBES

Issue/Introduction

We are not able to deploy WASP probe and we are getting an error specified file path not available. Note: Robot/agent seems to be working fine and its getting communication error post deploying WASP probe.

Cause

- compressed java folder

Environment

Release : 20.1

Component : UIM OPERATOR CONSOLE - WASP & CORE

OS: Windows Server 2012 R2 Standard

Resolution

Error in conroller.log:

Controller: Probe 'wasp' FAILED to start (command = ../../..//bin/java.exe -server -cp "lib/*;i18n" -Djava.util.logging.config.file=conf/logging.properties -Djava.security.auth.login.config=conf/NimJAAS.config -Djava.library.path=../../../lib -Djs.license.directory=conf com.nimsoft.nimbus.probe.service.wasp.Probe) error = (2) The system cannot find the file specified.  
Mar  2 21:23:43:495 [98704] 0 Controller: post-install '.\jre\extract_jre.bat jre-8u232b09-windows-x64.7z' returned 1

Does this file exist in the jre location mentioned? -> jre-8u232b09-windows-x64.7z

Login to the local machine where wasp is deployed.

Navigate to the jre folder inside the Nimsoft installation folder, for example->
(default path: C:\Program Files (x86)\Nimsoft\jre)

Check to see if the java folder is of a compressed format (this folder should be uncompressed

If so,

-> uncompress the java folder (through utilities like 7-zip) in the location ..\Nimsoft\jre

-> Restart the nimsoft robot service 

After following the above steps the wasp port and the PID should be assigned.