Error when try to modify an email address
search cancel

Error when try to modify an email address

book

Article ID: 210637

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

After deploying a new endpoint through Connector XPress, and try to modify the email address the following error message is displayed

 

[ApacheDS Worker-thread-22] (com.ca.jcs.core:com.ca.jcs.osgi.exchange.router.MessageRouter:556) ERROR  - JCS@XXXXXX: validation failure: <errorMessages><header>Error with eTDYNAccount[="dbo"."MyTableXXX"] object named 'eTDYNAccountName=MyUser,eTDYNAccountContainerName=Accounts,eTDYNDirectoryName=MyDYNEndpoint,eTNamespaceName=XXX,dc=im,dc=etasa':</header><messages><errorMessage>attribute eTDYN-str-multi-02[=UserEmail]: Invalid value '[email protected]' does not match email address regular expression '^[\w.%-]+@[\p{Alnum}.-]+\.[\p{Alpha}]{2,4}$'</errorMessage></messages></errorMessages>

Environment

Identity Manager 14.x

Cause

The current regular expression from the Connector XPress does not allow the domain name even it is a valid domain.

Resolution

Follow the steps in Connector XPress

1. Open Connector XPress

2. Right-click on the deployed connector in the right-panel within the Connector XPress and choose "Create Project"

3. With the project load, from the left-panel, click on "Custom Types"

4. Remove the "email" from the list of "Formatted String Types" section, see image below

5. Right-click on the deployed connector again in the right-panel within Connector XPress and choose "Deploy Metadata"

Note: If the Provisioning Manager is open, close and open it again