AAI 6.2.0 WARN [JammerManager] task failed.: java.lang.StackOverflowError seen in jaws.log after Root Cause Analyzer starts up

book

Article ID: 210616

calendar_today

Updated On:

Products

Automic Automation Intelligence

Issue/Introduction

INFO [RunCycle] Running Root Cause Analyzer for AutoSys

WARN [CommonVendorImpl] Releasing read lock (jammer for schedulers: "AutoSys"); held time: 0:07:52.5; waiting: 0

 

WARN [JammerManager] task failed.: java.lang.StackOverflowError
 at java.util.HashMap.hash(HashMap.java:339)
 at java.util.HashMap.put(HashMap.java:612)
 at java.util.HashSet.add(HashSet.java:220)
 at java.util.stream.ReduceOps$3ReducingSink.accept(ReduceOps.java:169)
 at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:175)
 at java.util.ArrayList$Itr.forEachRemaining(ArrayList.java:901)
 at java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)
 at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:482)
 at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:472)
 at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708)
 at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
 at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499)

 

ERROR [JammerManager] Interrupted: com.termalabs.common.JawsException: Error occurred in task.
 at com.termalabs.server.system.JammerManager.runTasksInParallel(JammerManager.java:885)
 at com.termalabs.server.system.JammerManager.runJammers(JammerManager.java:708)
 at com.termalabs.server.system.JammerManager.run2(JammerManager.java:322)
 at com.termalabs.server.system.JammerManager.run(JammerManager.java:239)
 at com.termalabs.server.system.ApplicationControllerService$2.run(ApplicationControllerService.java:268)
 at java.util.TimerThread.mainLoop(Timer.java:555)
 at java.util.TimerThread.run(Timer.java:505)

Environment

Release : 6.2.0

Component : AUTOMIC AUTOMATION INTELLIGENCE ENGINE

Resolution

Upgrade to 6.2.0-1 to resolve the errors above. 

Upgrading from 6.2.0 to 6.2.0-1 is a minor upgrade and will not need any database updates or updates to the reporting server software.