Installation of the WSS Agent is failing if an earlier version of WSSA was installed on the computer before
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Installation of the WSS Agent is failing if an earlier version of WSSA was installed on the computer before

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Article ID: 210498

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

For testing purposes or any reasons you may need to install an older version of the WSSA after uninstalling a later version.

In certain case the WSSA will refuse to install indicating an newer version of the product is already present.

Cause

The MSI based uninstallation process may have failed to remove product entries on the Registry user hive (HKCU\Installer\Products\<guid>)

Resolution

You will need to clean up the Windows registry of references from the previous (newer) WSS installation.

Important Note: this should be limited to the "Installer\Products" keys under HKCU or HKLM. Per Microsoft documentation, care must be taken when making deletions in the registry.

  • Open the registry and search for the "WSS Agent" string.
  • Check that the string is found in a product name key
  • Check that the dword version matches the previously installed version
  • Backup the registry key that contains the ProductName / Version entries
  • Delete the registry key that contains the ProductName / Version entries
  • Re-run this process until the registry is clean of "WSS Agent" installation references

Once the registry is clean of the later version data the MSI installation should complete without any issues.

 

Additional Information

In order to gather some additional information do help with debugging installation of WSS Agent on Windows, you can run with additional logging:

c:\path\to\installer.msi /L*V \path\to\output.log

After running, gather \path\to\output.log and check for errors in the log file.