Error: "No connection could be made because the target machine actively refused it" when Symantec Installation Manager is running
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Error: "No connection could be made because the target machine actively refused it" when Symantec Installation Manager is running

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Article ID: 210461

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Updated On:

Products

IT Management Suite Installation Manager (formerly AICM)

Issue/Introduction

SIM (Symantec Installation Manager) Configuration process is failing with error during an upgrade:

A critical error occurred:
No connection could be made because the target machine actively refused it 172.xx.xx.xx:80

Configuration failed while attempting: Configure Notification Server...

In the SIM logs, you may see a message like this:

ConfigureNS - task_Completed(): Configuration Task Configure Notification Server... Failed: Unable to connect to the remote server
Unable to connect to the remote server
   [System.Net.WebException @ System]
   at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Altiris.NS.Installation.ProductConfigurationWebServiceProxy.ConfigureProductBatchForUpgradeWithoutSQL(String[] paths)
   at Symantec.Installation.UpgradeConfigTask.<StartImpl>d__2.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Symantec.Installation.NSConfiguration.Tasks.SerialTask.<Start>d__0.MoveNext()

No connection could be made because the target machine actively refused it 172.xx.xx.xx:80
   [System.Net.Sockets.SocketException @ System]
   at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.ConfigureNS.task_Completed(Object sender, CompletedEventArgs e)
   at Symantec.Installation.NSConfiguration.Tasks.SerialTask.<Start>d__0.MoveNext()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.MoveNextRunner.Run()
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()

Environment

ITMS 8.x

Cause

Proxy server was blocking the connection to the SQL Server

Resolution

1. Launch SIM and under "Settings", remove the Proxy Setting (or verify that the right ones are in place) as shown here:

2. Run a full repair as the administrator: