New Robot is not showing in infrastructure manager after install via RPM or nimldr
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New Robot is not showing in infrastructure manager after install via RPM or nimldr

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Article ID: 210442

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Our newly installed Robot is not showing in infrastructure manager.

We tried using the RPM and also tried using nimldr, both methods appear successful, but robot is not showing up.

We are getting errors like this in the controller.log:

Mar  8 09:25:26:537 [139751036163904] 2 Controller: sockConnect - connect to (ip address) 48002 failed 110 (sfd=7)
Mar  8 09:25:26:537 [139751036163904] 1 Controller: nimRequest: SessionConnect failed: - (ip_address):48002
Mar  8 09:25:26:537 [139751036163904] 0 Controller: hub MY_HUB(ip address) NO CONTACT (communication error)

 

Or

May 20 04:57:41:803 [139931356006208] 4 Controller: sockCloseErr: 0x21f41b0 fd=7 (ip address)/48002 socket disconnected 
May 20 04:57:41:803 [139931356006208] 1 Controller: nimSessionWaitMsg: got error on client session: nims=0x21f41b0 fd=7 104

Environment

Release: Any

Component : UIM - ROBOT

installed via nimldr/rpm

Cause

network configuration

Resolution

In an error like the following, the last 3-digit number in the error message (e.g. 110 or 104 below) indicates the network error message that comes from the socket layer.

 

Mar  8 09:25:26:537 [139751036163904] 2 Controller: sockConnect - connect to (ip address) 48002 failed 110 (sfd=7)


May 20 04:57:41:803 [139931356006208] 1 Controller: nimSessionWaitMsg: got error on client session: nims=0x21f41b0 fd=7 104

 

"110" means "Connection timed out" which generally means that a port is not open on a firewall, or the packets are being silently dropped.

"104" means "Connection reset by peer" which generally means that something is forcibly refusing the connection - again this usually means that a firewall is dropping the traffic while issuing a TCP Reset to the sender.