20.1 to 20.3 upgrade failing

book

Article ID: 210433

calendar_today

Updated On:

Products

CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

Attempting to upgrade UIM from 20.1 to 20.3. The installer setupCAUIMServer on the UIM server passes all of the initial checks, but errors out mid-install. 

The Robot Watcher process is running and can be restarted, but it appears the controller robot is failing to start (can't connect/nothing listening on 48000)

Environment

Release : 20.1

Component : UIM - INSTALL

Resolution

Verify if the robot.cfg of the Primary hub contains the <plugins> section as below:

<plugins>  
<attr_publisher>    
pluginPath = plugins/attr_publisher/attr_publisher.dll
pluginName = attr_publisher
configPath = plugins/attr_publisher/attr_publisher.cfg
configSection = variables
active = 1
</attr_publisher>
<plugins>

If it exists then remove the <plugins> section entirely from the config and restart the Robot Watcher Service

Additional Information