User Favorites Menu rights not assigned

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Article ID: 210422

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The "User Favorites Menu - Edit" rights never get assigned to a Resource. The following steps are used to create the Resource:

1. Go to "Home" then under "Resource Management" and "Resources". 

2. Click "New" and proceed to create the Resource

3. Once the Resource is created go to "Administration" then under "Organization and Access" go to "Resources"

4. In the filter set the status to "Lock" and search for the Resource.

5. In the edit screen make a change to the User Name or Resource ID. Set the status to "Active" and save

6. Look at the Resource Access Rights, then "Instance", notice that the "User Favorites Menu - Edit" is missing

It is not possible to add this right through the interface.

You will need to use this document to manually assign the rights through the database:

https://knowledge.broadcom.com/external/article/19027/how-to-fix-missing-favorites-for-xog-imp.html

Cause

This is caused during step 5, when the User Name or Resource ID is changed prior to setting the Status to "Active"

Environment

Release : ANY

Resolution

During step 5, change the status to "Active", then "Save".

After the Save is completed the right will be assigned to the Resource.

You can then make any additional changes needed, including changing the User Name.