Rows in availability reports are limited

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Article ID: 210383

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

Trying to run an on-demand availability reports in Performance Center we increased the row limit to 6000 from 250.  We have approximately 3700 device and the reports we run never show more that 1175 rows.

Cause

Devices that were not on the report did not have an SNMP profile applied to the device. The likly reason being the SNMP profile was deleted while still being used by the DA

Environment

Dx NetOps Performance Management any version

Resolution

To resolve, do the following:

1. http://DA-HOST:8581/rest/profiles

  • Make a list of profile id's

2. Run the following vertica query: select item_id, name from dauser.v_item where item_id in (select item_id from dauser.v_attribute_instance where attr_qname = '{http://im.ca.com/inventory}ManageableDevice.SNMPProfileID' and long_value not in (profile id,profile id etc));

  • This will give a list of devices that do not have SNMP profiles applied (from step #1)
  • You can validate by looking the device up under Monitored devices, and checking the SNMP profile section under the 'Details' tab

3. Turn the list from step #2 into a text file of JUST hostnames.  Remove other columns and headers at the top

4. Import the list of hostnames and run discoveries

  • If the list is large you may want to consider discovering devices in 'chunks' rather than all at once
  • Once complete, assuming there are no issues you should now see the missing devices show up in the availability report after a few poll cycles

Any devices that are still missing should be looked at on an ad-needed basis