Unable to re-attach database to a SMP 8.5 RU4 server: You have selected an unsupported database version.

book

Article ID: 210323

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server) Installation Manager (formerly AICM)

Issue/Introduction

The customer is trying to re-attach his current database and he is getting the below error:

 

User prompt request: 'You have selected an unsupported database version '8.1 RU7, 8.5, 8.5 RU1-3' for upgrade.
Select either an existing Symantec_CMDB_8 database, or create a new database to complete the installation.': Result: OK (handled by user)
-----------------------------------------------------------------------------------------------------
Date: 3/10/2021 8:08:35 AM, Tick Count: 40007671 (11:06:47.6710000), Size: 540 B
Process: SymantecInstallationManager (10548), Thread ID: 16, Module: SymantecInstallationManager.exe
Priority: 8, Source: Symantec.Installation.Automation.Output.ReportVerbose

 

One customer gets this "You have selected an unsupported database version '8.1 RU7, 8.5, 8.5 RU1-3' for upgrade" when he was trying to select the new SQL Server and his moved database in the Database Configuration page (SIM>Configure Settings>Configure Database Settings). 

The other customer got this message when he migrated his SMP 8.5 RU4 to a new Windows Server 2019 (he migrated to the same 8.5 RU4 version) but when he tries to point to his existing database is when he gets the mentioned message.

If you check the DBSCHEMA table, you should see the right 8.5 RU4 value is there:

SELECT * FROM dbschema

 

Id            Version Build      Last Updated

1              8.0.2298.0            0              2017-03-03 08:15:35.560

2              8.1.4528.0            0              2017-09-02 09:14:40.407

3              8.5.3073.0            0              2019-03-09 19:31:38.990

4              8.5.4249.0            0              2019-05-31 19:40:34.237

5              8.5.5032.0            0              2020-02-28 19:56:57.443

6              8.5.5713.0            0              2020-07-31 19:35:56.880

 

Cause

Defect. This is not a problem with SQL Server version. Just some problem with DB version validation during switch when DB version is not the latest one. Easily reproducible with DB renaming and switching back to old one on same SQL. Not reproducible with 8.6 installation.

Environment

SIM version: 8.6.1026
Re-attaching a database to a 8.5 RU4 SMP Server.

Resolution

This issue will be fixed on a POST-8.6.1026 version of SIM.

Current workaround:

1. Close SIM
2. Open Regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Aim\
3. So create a key called "IgnoreDBUpgradeValidation" under "AIM" directory
4. Under "IgnoreDBUpgradeValidation" key, create a DWORD called "Enable" and place a value of 1.
5. Open SIM again and try again.

Additional Information

173436 "You have selected an unsupported database version '8.5' for upgrade"

Attachments