After reconfiguring the dashboard, licensing error on dashboard and some services fail to start
search cancel

After reconfiguring the dashboard, licensing error on dashboard and some services fail to start

book

Article ID: 210217

calendar_today

Updated On:

Products

Rally On-Premise

Issue/Introduction

The dashboard displays the following error in the upper right tile:

1 error occurred: * Service licensing failed with error: task: non-zero exit (1)

 

The Cluster tab shows the alm service in an orange starting state and the licensing service in a red failed state:

Environment

Release : 2.0+

Component : API FOR AGILE CENTRAL

Cause

This can be caused in some situations when reconfiguring LDAP and the LDAP Bind Username DN value is stored in a hidden JDBC user field

Resolution

SSH into services VM

Run the following commands:

$ replicatedctl app-config set jdbc_user --value ""
$ replicatedctl app apply-config -a