The SSH applet will briefly flash and close

book

Article ID: 210205

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When the customer attempts to connect to certain Unix/Linux endpoints, PAM will briefly flash the SSH applet, then it will close. After this, the customer cannot access ANY endpoints (even endpoints that were working prior to this connection attempt). Attempting to access another endpoint results in nothing flashed on the screen. This condition remains until the customer logs out of PAM.

Cause

The root cause for this issue is for some of the target devices the 'Cursor foreground', 'Foreground Color', and the 'Background Color' were blanked out for some unknown reason.

Environment

Release: 3.4.x 

PRIVILEGED ACCESS MANAGEMENT

Resolution

Change the 'Cursor foreground', 'Foreground Color', and the 'Background Color' as per the screenshot below:

 

Additional Information

Because of this while launching the MindTerm for those devices, it fails with java.lang.StringIndexOutOfBoundsException (listed below).

logs.log showing: 

===================================

2021-02-05 13:53:53 INFO  - java.lang.StringIndexOutOfBoundsException: String index out of range: 2     syserr [PAM Access Agent-7]
2021-02-05 13:53:53 INFO  -      syserr [PAM Access Agent-7]
2021-02-05 13:53:53 INFO  -     at java.lang.String.substring(String.java:1963)     syserr [PAM Access Agent-7]
2021-02-05 13:53:53 INFO  -      syserr [PAM Access Agent-7]
2021-02-05 13:53:53 INFO  -     at com.ca.xsuite.app.mindbright.application.MindTerm.convertColor(Unknown Source)     syserr [PAM Access Agent-7]

==================================