MS SQL 2019 Support Timeline

book

Article ID: 210119

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Hi,

Last year we upgraded our on premise Clarity install to 15.81, running on MS SQL 2016 SP2 servers.  Currently, MS is ending its mainstream support for SQL2016 this July and our company would like to move to SQL2019, however that version is not supported by Clarity.  We were wondering if there was a timeline for offering SQL2019 support, either natively or in compatibility mode, that you could share so we can plan accordingly.

 

Thank you,

Scott

Environment

CLARITY INTEGRATIONS & INSTALLATIONS

Resolution

As per the Engineering team, MSSQL 2019 is not certified yet and support for MSSQL 2019 is targeted for the Clarity 15.9.2 version, however please be informed that testing still needs to go through full QA before it is part of the officially supported components. Customers can either refer to Techdocs for Clarity 15.9.2 release to find the certified MSSQL versions or open a new case and Support can check.

CLARITY 15.8.1
Microsoft SQL Server 2017 Enterprise Edition
Microsoft SQL Server 2016 Enterprise Edition: Service Pack 2 or higher (higher is associated with service pack)

CLARITY 15.9.1
Microsoft SQL Server 2017
Microsoft SQL Server 2017 Enterprise (CU-21) (Full Mode)
Microsoft SQL Server 2016 Enterprise Edition: Service Pack 2 or higher (higher is associated with service pack)

CLARITY 15.9.2 (future release)
Support for MSSQL Server 2019 is targeted for 15.9.2, however testing still needs to go through full QA before MSSQL 2019 is officially supported. (Check the Techdocs for Clarity Hardware and Software Compatibility Specifications for the MSSQL certified versions.)

Additional Information

Jasper Reports Server v7.8 General Availability Announcement here.

As part of the Jaspersoft 7.8 testing we also certified JS with SQL Server 2017 and 2019.
Specifications: Jaspersoft Database Components

Microsoft SQL Server 2019 (Jaspersoft 7.8 only)
Microsoft SQL Server 2017 (Jaspersoft 7.8 only)
Microsoft SQL Server 2016 Enterprise Edition: Service Pack 2 or higher (Jaspersoft 7.1 and 7.8)
Microsoft SQL Server 2014 Enterprise Edition: Service Pack 2 or higher (Jaspersoft 7.1 and 7.8)