Fast Data Masker(FDM) launch error "The application requires a JRE 1.8.0"

book

Article ID: 210073

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We have recently installed FDM and unable to launch it as we are getting error, "The application requires a JRE 1.8.0".

We have installed open JRE and JDK and set the JAVA_HOME to JDK path and JRE_HOME to JRE path and also added JRE's bin path to the path Environment variable and still not able to launch.

Cause

The issue is specific to if you install the OpenJDK on server prior to installing TDM.

Environment

Release : 4.8, 4.9

Component : CA Test Data Manager - Fast Data Masker

Resolution

Remove TDM and then also remove the OpenJDK install from the server. Then run the TDM install again allowing TDM to install the OpenJDK. When the TDM installer installed the OpenJDK, it would work fine.