Unable to attach files with accents or Japanese name - error "virus was detected"
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Unable to attach files with accents or Japanese name - error "virus was detected"

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Article ID: 209985

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Error loading files with an accent or Japanese file name. The action errors out.  It happens in the attachment attribute fields, collaboration (documents) and Knowledge Base Store. It happens with multiple file types including emails and documents. Clarity is refusing the attachment appending documents.

STEPS TO REPRODUCE:

  1. Create a new attribute with Data Type "Attachment" and add it to a View.
  2. Click on 'Choose a file' button and select a file with Japanese file name.
  3. Click on 'Save' button.

Expected Results:  The file is uploaded.
Actual Results:  "ERROR The following file(s) were not uploaded, because a virus was detected: (file name)

Or you may see: No se han cargado los archivos siguientes porque se ha detactado un virus.

Environment

Clarity GCP 15.9.0, 15.9.1

Cause

This is caused by DE59786

Resolution

This is fixed in 15.9.2

Workaround: Rename the Japanese file name with English name / Remove the accent in document names.