Not able to import/export cabi reports and settings

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Article ID: 209968

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Updated On:

Products

DX Infrastructure Management

Issue/Introduction

Tried to export the cabi report and setting via cabi url before upgrade the cabi probe, but failed. Login to cabi page > Manage > Server settings > Export. After I click on the Export.

 

Cause

The existing config skipped the JAR files scan so it was failing to load the required info from some JARs.

Environment

Release : 20.3

Cabi probe: 4.3 bundled

Component : UIM - CABI

Resolution

On CABI's latest context.xml(context file in cabi from wasp/conf) :
 
change the following line:
--------------------------------------------
<JarScanFilter pluggabilitySkip=".jar" defaultPluggabilityScan="false" tldSkip=".jar" defaultTldScan="false"/>
 
to the following:
----------------------------
<JarScanFilter pluggabilitySkip="*.jar" defaultPluggabilityScan="false" defaultTldScan="true"/>
 
and restart CABI robot.
 
Note: perform this by having a backup of the original file.

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