Protection Engine errors "Group not resolved" and "Group name not present Error code :12000"
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Protection Engine errors "Group not resolved" and "Group name not present Error code :12000"

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Article ID: 209952

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

Symantec Protection Engine (SPE) logs show the following error:

Sat Mar 06 00:02:17 Pacific Standard Time 2021
Group name could not be resolved.
Event Severity Level = Error
Error Message = Group name not present Error code :12000
Symantec Protection Engine IP address = 192.0.2.2
Uptime (in seconds) = 2
Date/time of event(with millisec) = 1615017737138
Symantec Protection Engine Host Name = scanner
Process ID = 4608

Environment

SPE installed on Windows

Cause

ADAuthenticationMode is enabled with no entry for the ActiveDirectoryDetails groupname.

Resolution

ADAuthenticationMode is only used to configure whether or not the local Java console should use Active Directory authentication. The ActiveDirectoryDetails groupname defines which group users need to be a member of in order to log in to the java console. If you not using the local Java console, you should disable ADAuthenticationMode. If you are using the local Java console, you should either disable ADAuthenticationMode or you should define a group to use to log into the console by populating the ActiveDirectoryDetails groupname.

Disabling ADAuthenticationMode

  1. Launch command prompt as administrator
  2. Change directory to SPE's installation directory.
  3. Run the following command:
    • .\XMLModifier.exe -s /configuration/Resources/System/admin/ADAuthenticationMode/@value false configuration.xml
  4. Restart the Protection Engine service.

Populating the ActiveDirectoryDetails groupname

  1. Launch command prompt as administrator
  2. Change directory to SPE's installation directory.
  3. Run the following command, replacing <domain\groupname> with your chosen active directory group name:
    • .\XMLModifier.exe -s /configuration/Resources/System/admin/ADAuthenticationMode/ActiveDirectoryDetails/@groupname <domain\groupname> configuration.xml
  4. Restart the Protection Engine service.