CMDB Visualizer doesn't load after enabling SSL

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Article ID: 209925

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

CMDB Visualizer doesn't load after enabling SSL. Error in pdm_tomcat_VIZ.log:

Caused by: java.io.FileNotFoundException: <local drive>\Service Desk Manager\bopcfg\www\CATALINA_BASE_VIZ\conf\localhost-rsa.jks (The system cannot find the file specified)
 at java.base/java.io.FileInputStream.open0(Native Method)
 at java.base/java.io.FileInputStream.open(FileInputStream.jav

Cause

server.xml is calling a localhost-rsa.jks keystore which does not exist

Environment

Release : 17.3

Component : SERVICE DESK MANAGER

Resolution

Configure server.xml SSL connector properly. You can take the server.xml from SDM, REST, etc.. as an example.

Example:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-2/administering/configure-ca-service-desk-manager/managing-servers/how-to-configure-ssl-authentication.html