Use dirscan to monitor a shared file system or path | Cannot detect existing folder path on specific server
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Use dirscan to monitor a shared file system or path | Cannot detect existing folder path on specific server

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Article ID: 209921

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

  • Need to monitor a shared file system\location on the server.
  • DIRSCAN probe cannot detect existing folder path on specific server

 

Example: \\<servername>.global.<domain>.net\<hostnam>\<profile>\

Environment

  • DX UIM 23.4.*
  • Component : UIM - DIRSCAN
  • dirscan probe v3.19 or higher

Cause

  • NFS/network share monitoring Guidance
  • Known issues and requirements

Resolution

NOTE:

  • It is possible to monitor a shared drive, but on Windows only. 
  • Non-Windows remote directories cannot be monitored.

Requirements: 

 

  • You cannot run batch files from a mapped drive using the dirscan probe

  • Non-Windows remote directories cannot be monitored

  • The underlying storage device where the file system is hosted does not matter to the probe.  As long as the probe can access the desired directories/files to be monitored on the shared file system, then it will be able to monitor them.

  • If the The probe installed on a Windows robot where you can access for example, the "\\Windows_Robot_Server.fully.qualified.domain\XXXX_ACL_NNNNNN\M_TEST\INT\ZZZ\ABC" shared directory, you should be able to monitor the directory using the dirscan probe.



■  When you create the dirscan profile and enter the shared directory name in the Directory field on the Scan Directory tab of the New Profile dialogue, you will also be asked to provide the username and password that has the access/permissions required to access the network drive.  Once the correct information is provided and the profile is created, the probe will be able to monitor the network drive. For example, the userid could be the administrator, domain administrator or a service account.


Issues: (Cannot detect existing folder path on specific server | Issues find the shared drive)

  • Note on intermittent alarms being thrown for network shares not found: 
    Check network connectivity / latency / DNS timeouts. In the case of DNS timeouts, try adding an entry for the destination hostname on the source server in the /etc/hosts file.
  • If some files are not displaying when you Browse for the files on the filesystem, check with your sys admin on file type, availability and any security or permissions that may be interfering with file access. 

  • In some scenarios, if files or the entire folder, is not appearing in the DIRSCAN probe and everything else is checked | if the probes does not detect a folder even though Windows can with the same credentials, plan a server reboot as this might resolve the issue. After reboot files may be showing correctly.

Additional Information