How to use dirscan to monitor a shared file system or path
search cancel

How to use dirscan to monitor a shared file system or path

book

Article ID: 209921

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

We need to monitor a shared file system\location on the server, can you please let me know if it is possible?

For example-> \\NetAppXXXXXXX.global.NNNNN.net\SXXXXDATA\XYZProfile\"

Environment

  • Release: 9.2.0 or higher
  • Component : UIM - DIRSCAN
  • dirscan probe v3.19 or higher

Cause

  • NFS/network share monitoring

Resolution

It is possible to monitor a shared drive, but on Windows only

Non-Windows remote directories cannot be monitored.

The dirscan probe can successfully monitor shared file systems with the following exceptions:

  • You cannot run batch files from a mapped drive using the dirscan probe
  • Non-Windows remote directories cannot be monitored

The underlying storage device where the file system is hosted does not matter to the probe.  

As long as the probe can access the desired directories/files to be monitored on the shared file system, then it will be able to monitor them.

As long as the dirscan probe is installed on a Windows robot where you can access for example, the "\\Windows_Robot_Server.fully.qualified.domain\XXXX_ACL_NNNNNN\M_TEST\INT\ZZZ\ABC" shared directory, you should be able to monitor the directory using the dirscan probe.

When you create the dirscan profile and enter the shared directory name in the Directory field on the Scan Directory tab of the New Profile dialogue, you will also be asked to provide the username and password that has the access/permissions required to access the network drive.  Once the correct information is provided and the profile is created, the probe will be able to monitor the network drive. For example, the userid could be the administrator, domain administrator or a service account.

Additional Information

 
Note on intermittent alarms being thrown for network shares not found-> Please check network connectivity / latency / DNS timeouts. In the case of DNS timeouts you could try adding an entry for the destination hostname on the source server in the /etc/hosts file.
 
 
If some files are not displaying when you Browse for the files on the filesystem, check with your sys admin on file type, availability and any security or persmissions that may be interfering with file access. 
 
You can also try rebooting the server where the robot and dirscan probe are installed as in some rare cases, after a reboot, files will then display as expected.