Data Aggregator cannot be accessed after upgrade
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Data Aggregator cannot be accessed after upgrade

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Article ID: 209900

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

DA cannot be accessed after upgrade in a Fault Tolerant Data Aggregator environment

When I try and put either DA into active or maintenance state there is an error similar to:

/opt/IMDataAggregator/scripts/dadaemon activate
cat: /DASharedRepo/acl-token.properties: No such file or directory:

Where /DASharedRepo is the shared directory for the Data Aggregators.

Also in the /opt/IMDataAggregator/InstallLogs_ConsulServer/CA_Installer_for_Consul_Install_MM_DD_YYYY_HH_MM_SS.log we see errors such as:

                       Status: ERROR
                          Additional Notes: ERROR - Error while boostrapping ACL: Request to Bootstrap ACL failed. ACL might be in legacy mode or might have already been configured HTTP Error Code: 500, response: Internal Server Error

Custom Action:            com.ca.im.consul.ext.installer.customercode.BootstrapAcl
                          Status: FATAL ERROR
                          Additional Notes: FATAL ERROR -     class com.ca.im.consul.ext.installer.customercode.BootstrapAcl FatalInstallException: HTTP Error Code: 500, response: Internal Server Error

Environment

All supported DX NetOps Performance Management releases

Cause

There are a few possible causes for this error.

  1. When running a new Fault Tolerant (FT) Data Aggregator (DA) install:
    • Seen during first DA install? Did the first run fail and now we see this when Running new install attempt before second DA is installed?
    • Seen during second DA install? Are all ports open per the chart on the Install Fault-Tolerant Data Aggregators documentation topic.
  2. When upgrading the Fault Tolerant Data Aggregators the following could be seen.
    • The Data Aggregator Proxy was not been upgraded before upgrading the DA(s).
    • The DA Proxy was upgraded after the Data Aggregators

Resolution

To resolve these issues follow these steps.

  1. Seen during new installs? Ensure correct ports are open and re-run installs.
  2. During an upgrade? Run the upgrade installs in the correct order.
    1. If this is an upgrade: ***Do NOT uninstall the Data Aggregator before re-running the installer***
    2. Uninstalling the DAs from an existing environment should ONLY be done under support direction.

Additional Information

Note this also may be seen if a shared data directory is not being used, this is required for a Fault Tolerant Data Aggregator per the documentation.