System error any time we try to edit a portlet Filter Field in Admin

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Article ID: 209817

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

We receive the following error any time we try to edit a portlet Filter Field in Admin.  This is happening for all portlets: existing and custom.

This is happening on the Admin side only.  Portlets can still be configured by users.

This is preventing the development and configuration of portlets

Cause

com.niku.union.persistence.nsql.NSQLSyntaxException: NSQL Syntax exception: NSQL_SYNTAX_ERROR_DB_ERROR, Info: ERROR: relation "odf_ca_bc_customer_site" does not exist
  Position: 399
SQL Text:
 SELECT
						Q.SUPPORT_SITE_DB_ID AS SUPPORT_SITE_DB_ID,
						Q.SUPPORT_SITE_NAME AS SUPPORT_SITE_NAME, 
						Q.SUPPORT_SITE_ID AS SUPPORT_SITE_ID, 
						Q.CLASSIFICATION AS CLASSIFICATION
						FROM (
							SELECT DISTINCT
							SITE.ID SUPPORT_SITE_DB_ID,
							SITE.NAME SUPPORT_SITE_NAME,
							SITE.BC_SUPPORT_SITE_ID SUPPORT_SITE_ID, 
							ACCT_CLASS.NAME CLASSIFICATION
							FROM ODF_CA_BC_CUSTOMER_SITE SITE
							JOIN INV_INVESTMENTS ACCT ON ACCT.ID = SITE.BC_ACCOUNT
							JOIN ODF_CA_BC_ACCOUNTS ODFA ON ODFA.ID = ACCT.ID
							JOIN ODF_CA_BC_LICENSEE LIC ON LIC.ID = SITE.BC_LICENSEE
							-- Account Classification --
							LEFT JOIN CMN_LOOKUPS_V ACCT_CLASS ON ACCT_CLASS.LOOKUP_CODE = ODFA.BC_ACCOUNT_CLASS
								AND ACCT_CLASS.LOOKUP_TYPE = 'BC_ACCOUNT_CLASS'
								AND ACCT_CLASS.LANGUAGE_CODE = 'en'	
							WHERE ? = ACCT.ID	
							) Q
						WHERE 1=? and 1=1 and 2 = 2 

Environment

Release : 15.9

Component : CA PPM SAAS STUDIO

Resolution

There was an inactive lookup attribute that was referencing old custom object which was deleted. Deleted the attribute and lookup and that fixed the issue.