Failed to get configuration from IM: Internal Server Error:
search cancel

Failed to get configuration from IM: Internal Server Error:

book

Article ID: 209784

calendar_today

Updated On:

Products

CA Identity Suite

Issue/Introduction

While creating a new universe in CA Identity Manager (IG) and providing the CA Identity Manager (IAM) connection details, the test connection fails with the following error: 

16:33:04,112 ERROR [com.ca.clientconnection.WebServiceHandler] (default task-39) WebServiceHandler.getWSConfigurationJSON:  Failed to get configuration from IM for: Failed to get configuration from IM: Internal Server Error: com.ca.clientconnection.clientapi.ClientConnectionException: Failed to get configuration from IM: Internal Server Error
        at com.ca.clientconnection.clientimpl.util.WebServiceHandler.getWSConfiguration(WebServiceHandler.java:419) [clientconnection-impl.jar:]
        at com.ca.clientconnection.clientimpl.WSConfiguration.getWSConfiguration(WSConfiguration.java:85) [clientconnection-impl.jar:]
        at com.ca.clientconnection.clientimpl.WSConfiguration.registerRCM(WSConfiguration.java:53) [clientconnection-impl.jar:]
        at com.ca.clientconnection.clientapi.Configuration.registerRCM(Configuration.java:28) [clientconnection-api.jar:]

 

 

Environment

Release : IM 14.4.1CHF2, 14.3 CP2, IG 14.3 CP2

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

The IG Error has a corresponding IM Error.  These point to an issue with the RACF Connector.
 
IG Error:
15:13:44,427 ERROR [com.ca.clientconnection.WebServiceHandler] (default task-48) WebServiceHandler.getWSConfigurationJSON:  Failed to get configuration from IM for: Failed to get configuration from IM: Internal Server Error: com.ca.clientconnection.clientapi.ClientConnectionException: Failed to get configuration from IM: Internal Server Error
at com.ca.clientconnection.clientimpl.util.WebServiceHandler.getWSConfiguration(WebServiceHandler.java:419) [clientconnection-impl.jar:]
at com.ca.clientconnection.clientimpl.WSConfiguration.getWSConfiguration(WSConfiguration.java:85) [clientconnection-impl.jar:]
at com.ca.clientconnection.clientimpl.WSConfiguration.registerRCM(WSConfiguration.java:53) [clientconnection-impl.jar:]
at com.ca.clientconnection.clientapi.Configuration.registerRCM(Configuration.java:28) [clientconnection-api.jar:]
 
IM Error:
2021-02-23 15:13:44,423 ERROR [io.undertow.request] (default task-78) UT005023: Exception handling request to /iam/im/ws/wsconfiguration/identityEnv: javax.servlet.ServletException: java.lang.IllegalArgumentException: Object type User_Defined_Field is not valid for extension RACF v2
at org.glassfish.jersey.servlet.WebComponent.serviceImpl(WebComponent.java:432) [jersey-container-servlet-core.jar:]
 

Resolution

This is a known issue recorded in DE513491. Please raise a Support call ticket and request for hot-fix attached to DE513491.

We can also work around this problem if the RACF connector is not being used, simply remove it from the Webservices Configuration.

1. Log in to the IM User Console. 

2. Navigate to Tasks - > Roles and Tasks - > Admin Tasks - > Modify Admin Task

3. Search for Modify Web Services Configuration.

4. Clear the Hide in Menus check box and Submit button.

5. Navigate to Tasks -> System -> Webservices - > Modify Web Services Configuration.

6. Select IMRCM

7. Click on the Object Types Tab

8. Deselect (clear) all RACF objects and save.

After making the changes restart IM and IG.

 

 

Enable Modify Admin Task option

- From Identity Manager Console, select