Performance issue in Timesheet grid in modern UX
search cancel

Performance issue in Timesheet grid in modern UX

book

Article ID: 209655

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Performance lag when filtering on certain attributes like Active. Manager and Status in Modern User Experience (UX) timesheet grid with medium to large dataset where active users are more than 5k.

STEPS TO REPRODUCE: 

  1. Login to Clarity and Navigate to modern UX
  2. On the modern ux navigate to timesheet workspace and click on Timesheets Grid
  3. Use common component filter and add Status = open & Returned and Active = Yes 

Expected Results: The data retrieval should be fast  and within reasonable time 
Actual Results: The data retrieval takes around 5 minutes or more for a record set of 85k with filter 

Environment

Release : 15.9.1, 15.9.2, 15.9.3,16.0.0

Component : CLARITY SAAS TIME MANAGEMENT

Cause

  • This is reported as DE59958 & DE62531.
  • The Timesheet grid page will display both open and closed time periods by design till clarity version 15.9.2, from 15.9.2 Patch 1 we are adding implicit filter and its documented in KB: Timesheets on Closed Time Periods in MUX.
  • Also this will show data irrespective of the resource termination date

Resolution

DE62531 has been fixed as part of 16.0.1. However, more improvements need to be done and this will taken up as part of a feature for future clarity releases. 

Workaround: Remove the filter and data retrieval should be  fast and also reduce the dataset by applying filters on Resource ID till the defect is fixed