Software update has exceeded maximum reapplication retries (4)
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Software update has exceeded maximum reapplication retries (4)

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Article ID: 209619

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Updated On:

Products

Patch Management Solution

Issue/Introduction

When doing monthly patching to Windows computers there are a few systems that fail to install some updates as seen in the following message.  What causes this and how can it be resolved?

  • Severity: 4
  • Date: 2/24/2021 5:00:10 PM
  • Tick Count: 401048625
  • Host Name: xxx
  • Process: AeXNSAgent.exe (6016)
  • Thread: 936
  • Module: PatchMgmtAgents.dll
  • Source: SoftwareUpdateAgent
  • Description: Software update [AcroRdrDCUpd2100120135.msp] has exceeded maximum reapplication retries (4)

Environment

ITMS 8.x

Cause

By default Patch Management will only try installing an update 3 times.  This option exists so that updates that fail to install won't continue to install and fail over and over again.  This is configurable in the SMP Console at:

Setting > All Settings > Settings > Agents/Plug-ins > Software > Patch Management >  Windows > Default Software Update Plug-in Policy (in the Installation Schedules tab)

NOTE: Before elevating this value you generally should attempt to determine why the installation attempts are failing and the agent.log files can help identify this.  

Resolution

The "Reinstallation attempts after task failure ..." can be increased to help identify the root cause of an update failing to install.  General suggestions to follow would be:

  • Select a test machine and try running the update manually (from the Software Delivery > GUID > Cache folder) and see if the update will run.  If it doesn't, note the error received and determine if there is an issue with the installer.
  • Elevate the "Reinstallation attempts after task failure ..." value to something like 5 or 6 or something that makes sense to you while troubleshooting
  • You may need to disable/enable the policy before it will attempt to install again, and in a few cases you may need to disable the policy and create a new policy for the update before it will try and install again (you will need to wait for the configuration updates to run or run this manually)
  • If the update fails to install again then check the agent.log files to help determine why it is failing to install
  • Once you get the updates to install or know the reason it wasn't installing it is suggested that you consider setting the value back to the default