Manage Connections Profile page fails to load with HTTP Error 500.19
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Manage Connections Profile page fails to load with HTTP Error 500.19

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Article ID: 209399

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

The Manage Connections Profile page fails to load with HTTP Error 500.19 as seen in this screenshot:

Settings > Monitoring and Alerting > Protocol Management > Connection Profiles > Manage Connection Profiles

Environment

Monitor Solution 8.x

Cause

The Notification Server was installed to a drive letter other than C:\, the E:\ drive, and for some reason, the "Physical Path" pointed to the C:\ and not the installed drive path. 

Did a repair/reconfig in SIM and the issue still existed.  Replaced the web.config, exported/imported the page from a working NS with the same results. IIS showed the following but there were no errors in the Event View logs:

2021-02-19 17:57:26 10.100.8.16 GET /Altiris/PluggableProtocols/ConnectionProfileControlConsumer.aspx Url=https://<SMP-SERVER/altiris/console/tree.aspx?ViewGuid=a57fb0e9-0676-4e00-929a-6bb37dc1f888&&ConsoleGuid=1b22db4e-a898-443f-9b99-855b1653d3f5&TreeGuid=a57fb0e9-0676-4e00-929a-6bb37dc1f888&ParentGuid=00000000-0000-0000-0000-000000000000&ItemGuid=f6aed14a-3177-4f14-93ac-dd062a697050&ViewGuid=a57fb0e9-0676-4e00-929a-6bb37dc1f888&ConsoleGuid=1b22db4e-a898-443f-9b99-855b1653d3f5 443 - 172.20.33.212 Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/88.0.4324.150+Safari/537.36 https://<Server>/altiris/console/tree.aspx?ViewGuid=a57fb0e9-0676-4e00-929a-6bb37dc1f888&&ConsoleGuid=1b22db4e-a898-443f-9b99-855b1653d3f5 500 19 3 15

Resolution

The IIS "Physical Path" for the Pluggable Protocols was set to the C:\ and changing it to the E:\ drive resolved the issue.  In IIS under Connections, go to:

[ServerName] > Sites > Default Web Site > Altiris > Pluggable Protocols

Then select Advanced Settings and changed the Physical Path as shown here: