WA Agent for i5/OS (AS/400) doesn't start after IBM JRE patch is applied

book

Article ID: 209321

calendar_today

Updated On:

Products

CA Workload Automation Agent CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation DE - System Agent (dSeries) CA Workload Automation Agents

Issue/Introduction

After the PTFs were applied on iSeries WA Agent, the agent stops with this error


main.MainThread.CybTcpipControllerPlugin.initialize[:314] - cybermation.library.security.CybSecurityException: java.security.NoSuchProviderException: JCE cannot authenticate the provider JsafeJCE

             

 

Cause

The JsafeJCE jar certificate is not recognized due to new JRE update.

Environment

Release : 11.3, 11.4

Component : CA WORKLOAD AUTOMATION AGENT for iSeries

Resolution

The WA Agents 11.5 and above now uses different crypto libraries.  The agent has to be upgrade to resolve the JsafeJCE issue.