Some Agents not reporting data

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Article ID: 209202

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Updated On:

Products

DX Application Performance Management

Issue/Introduction

After APM Agent is configured, we are getting protocol version error while agent trying to connect to DX APM endpoint URL.
5 Weblogic Agents were deployed in our environment. 2 Agents are reporting the metrics successfully. 3 Agents are not reporting the metrics due to connection failure. We see the following error in the agent log.
 
[ERROR] [IntroscopeAgent.IsengardMessaging] WebSocket Client caught io.netty.handler.codec.DecoderException: javax.net.ssl.SSLException: Received fatal alert: protocol_version
[WARN] [IntroscopeAgent.ConnectionThread] Failed to connect to the Introscope Enterprise Manager at apmservices-gateway.mydomain.com:443,com.wily.isengard.client.transport.websocket.SSLWebSocketFactory (io.netty.handler.codec.DecoderException:javax.net.ssl.SSLException: Received fatal alert: protocol_version).
[WARN] [IntroscopeAgent.ConnectionThread] Failed to connect to the Introscope Enterprise Manager at apmservices-gateway.mydomain.com:443,com.wily.isengard.postofficehub.link.net.HttpsTunnelingSocketFactory (com.wily.isengard.postofficehub.link.http.client.HTTPNotRunningException:The HTTP Tunneling server cannot be reached at: https://apmservices-gateway.mydomain.com:443/em/transport/services/IsengardHttpTunnelingService: Error when connecting to tunneling server: status=-1).
 

Cause

Likely cause of this issue is the JVM version of the Application Server.

The agent log is showing following JVM version.

[INFO] [IntroscopeAgent.GC Event] Java Version is '1.6.0_17'.

Environment

Release : 20.11

Component : APM Agents

Resolution

Check the agent log and try to find the JVM version that agent is using.

[INFO] [IntroscopeAgent.Properties] java.runtime.name=Java(TM) SE Runtime Environment
[INFO] [IntroscopeAgent.Properties] java.runtime.version=1.6.0_17-b04

In this case, the WebLogic Server is using Java 1.6.

Please consult with Application Server Admin and confirm this.

Also, inquire with Application Server admin if they can upgrade the Java version that this WebLogic Server is using.

Once you upgrade the Java to 1.8, this issue should not occur anymore.

Another workaround is to use the cloud proxy.