API Management: Cannot download files/patches/updates via Chrome web browser

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Article ID: 209093

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Updated On:

Products

CA API Developer Portal API SECURITY API MANAGEMENT SAAS CA API Gateway CA API Gateway Enterprise Service Manager (Layer 7)

Issue/Introduction

This article will discuss why downloading files from the Solutions & Patches page no longer works for users of the Chrome web browser, and what alternative solutions exist. This issue only affects Chrome users as it was due to a change in the Chrome web browser itself. This is not due to any server-side issue.

Cause

As of Chrome 88, FTP support was completely removed from the Chrome browser world-wide. This means users running Chrome 88 or higher can no longer directly download from FTP servers. Chrome now instead prompts a user to use an FTP client if one exists on the computer, or throws different errors. This process started in Chrome 86 though, so some users on Chrome 86 or 87 may also experience this behaviour.

Environment

This article applies to anybody running the Chrome web browser to download files from the API Management Solutions & Patches pages for the various APIM products, including files from the following Solutions & Patches pages:

Resolution

Due to the limitation in Chrome, a user may use other web browsers such as Firefox or Safari, or download using an actual FTP client instead. Chrome should prompt to open one if one exists, as seen in the prompt screenshot below:

Proposed solutions:

  1. Download the file(s) from a different web browser such as Firefox or Safari
  2. Use an FTP client such as Cyberduck or WinSCP to download the file(s)
  3. Consider re-enabling FTP support in the Chrome web browser if still possible via their control flags

Additional Information

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