Missing tables and columns after upgrade

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Article ID: 209090

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Updated On:

Products

CA Service Desk Manager

Issue/Introduction

Upgraded SDM from 17.3 to 17.3.02  and now unable to update contacts, make requests or generate CIs. 

There are missing columns and tables in the Database.  There are several z* fields.

Cause

upgrade didn't generate the columns

Database doesn't match the ddict.sh file

Environment

Release : 17.3

Component : SERVICE DESK MANAGER

Resolution

1. open web screen painter on the background server

2. look at the schema design too (for a different issue).

3. It will show that the schema didn't match the database

4. generate the files needed for the pdm_publish. How to Modify Schema Using Web Screen Painter

5. Restart Server

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-3/building/building-ca-service-desk-manager/web-interface-modifications/how-to-modify-schema-using-web-screen-painter.html