Is it possible, to execute an R19 Package in an R20 Plan for CA DB2 Tools?

book

Article ID: 209053

calendar_today

Updated On:

Products

CA Database Management for DB2 for z/OS - Administration Suite CA Database Management for DB2 for z/OS - Performance Suite CA Database Management for DB2 for z/OS - Recovery Suite CA Database Management for DB2 for z/OS - SQL Performance Suite CA Database Management for DB2 for z/OS - Utilities Suite

Issue/Introduction

The DB2 tools were upgraded from R19 to R20. As a precaution, the existing R19 collections along with the new R20 collections  were bound in DB2 plans. The tools seem to be working fine under R20. Executing  the old R19 packages by using the old R19 load libraries failed with the following error  message. Can the R19 plans be executed if needed? 

The error is "Unable to establish XMANAGER connection.  Verify PARMLIB(SETUPxx) XMANID parm and the started task.
SSI100I      PTRP001A STEP IMAGCOPY EXEC COMP( 0036)  <--- NON-ZERO RETURN CODE

 

Environment

Release : 20.0

Component : CA Quick Copy for DB2 for z/OS

Resolution

Packages of different releases like R19 and R20 can not be mixed or bound together.